Installation error

Jun 29, 2010 at 2:38 PM
After I run install.cmd, two errors occured when running these codes in install.cmd: dism /online /enable-feature /featurename:NetFx2-ServerCore dism /online /enable-feature /featurename:MicrosoftWindowsPowerShell I've noticed that I have to install .net 2.0 and powershell before intallation, I'm using windows server 2008 R2 so seems no need to install powershell. But install.cmd reports me that it can't find both of two features (.net 2.0 and powershell) What is more strange, I can go on with installation, and I saw hyper-v module installed when I input Get-Module, and I can use cmdlet such as Get-VM. Does those errors matter to my installation? Thanks!!!
Aug 10, 2010 at 9:07 AM

I have exactly the same error message. Could you solve it? Does it matters?

Thanks for answers

Sep 14, 2010 at 8:19 AM

These errors occur because you are installing on full version of Windows Server 2008 R2. NetFx2-ServerCore and MicrosoftWindowsPowershell features are Core and Hyper-V Server R2 specific, because these component are all ready included in full installation. I does not matter your installation.

 

- jere

Sep 30, 2010 at 2:23 AM

Thanks very much for your help! :)

Oct 22, 2010 at 6:56 PM
Edited Oct 25, 2010 at 5:19 AM

However, I have an additional error... the import-module task fails in install.cmd.  PS is telling me that no valid module is found?  No idea how to solve this one.  Installation on full (Windows 2008 R2 Enterprise) by the way, not core.

Update, I found a work around.  Even after I set the executionpolicy to unrestricted, import-module kept demanding a signed module load.  Setting the registry to unrestricted by default, did not seem to help.  However, following the steps to re-establish a new profile or zero-ed profile, and in that (user) profile setting the executionpolicy value to unrestricted, did in fact fool or force import-module to work as/in unrestricted mode.  Import of HyperV module was successful using the new/clean profile with set-executionpolicy explicitly set to unrestricted.

This thread gave me the idea to try zeroing or re-establishing the user profile...
http://pshyperv.codeplex.com/Thread/View.aspx?ThreadId=62355