No reaction at all to any command

Mar 11, 2011 at 7:59 AM
Hi everybody
This would be a big help for me this tool BUT: when I started with the installation and it first came up with the powershell screen, I was able to send commands and it worked.

Now, when I start my powershell I do this steps, but nothing happens:
Import-Module HyperV
Stop-VM -VM Test_Computer
--> no reaction, no question, if I really would like to stop the VM, no stopping action in Hyper-V Manager...
Also the proposition from jamesone just returns a empty screen:
"This should be posted in the discussions area.
Start with Get-VM does it return any VMs ? "
PS C:\Windows\System32\WindowsPowerShell\v1.0> Get-VM
PS C:\Windows\System32\WindowsPowerShell\v1.0>

Does anybody know, what's the problem?
Thanks
ASchwerzmann
Coordinator
Mar 19, 2011 at 1:36 AM

What OS are you running on. ?

I've seen a problem which we haven't been able to resolve, and it only seem to happen on Datacenter.

Here is a test you can try, because if this works the library should work.

From the start menu run wbemTest , click connect (top right) and change root\cimV2 to root\virtualization and click connect. Then click enum classes type MSVM_computerSystem and click OK.

This should give you a list of VMs. If you don't WMI is not working properly on the machine and the library won't work. 

If this does give you a list of VMs, then we can see if we can figure out what's broken.

 

 

 

 

Mar 25, 2011 at 10:40 AM

Hi Jamesone

Thank you very much for your answer. It really gave nothing, when I tried to get out the VMs with the wbemTest. Is there maybe a fix needed? An update or something like that? I run a Windows Server 2008 R2 Enterprise SP1.

Thank you for your help! As already told: the tool is great, but it just works the first time, the install.bat is executed. After that it isn't working anymore.

ASchwerzmann

Nov 1, 2011 at 3:55 PM

Better late than never...

I had the same problem.
The user you started your script with is not a member of the Domain Administrators group.
You can add domain groups that are allowed to start/stop VM's.
This is done with the Authorization Manager, see: http://blogs.msdn.com/b/virtual_pc_guy/archive/2008/01/17/allowing-non-administrators-to-control-hyper-v.aspx
For some weird reason I could not add local groups, I had to select a Domain Group.

Nov 3, 2011 at 9:43 AM

At the first you should check wheather you are a member of group, which has wrights to work with Hyper-V (Domain Admins, Local Admins, maybe SCVMM admins if you have a SCVMM).

At second - If yes - check wrights at the Authorization Manager (mmc.msc -> File -> Add/Remove Snap-in -> Authorization Manager - Right click: Open Authorization Store: XML file -> Open: c:\ProgramData\Microsoft\Virtual Machine Manager\HyperVAuthStore.xml) Role assignments for users (HyperVAuthStore.xml -> Virtual Machine Manager -> Role Assignments -> Administrator). Assign group or user from AD or local with Administrator in Authorization Store.

At third - just check execution policy of PowerShell (Get-ExecutionPolicy -List). Must be Unrestricted for CurrentUser or for LocalMachine (Set-ExecutionPolicy -Scope CurrentUser Unrestricted).

Waiting for answer.

P.S. Sorry for my bad English.

Nov 3, 2011 at 12:32 PM

My accounts where member of the local administrators group, but still the scripts didn't work.
I had to add a Domain Group to get it working. (adding a local group wasn't possible!)

Nov 4, 2011 at 5:47 PM

Hi,

I'm sorry, I cannot check if your answers are working. I don't work anymore on this environment - so, sorry, but I hope this post will help someone else.

So sorry

ASchwerzmann

Nov 7, 2011 at 8:26 AM

You don't have to appologize, you're trying to help, that's enough!